
Chapter 2

A Quick Introduction to MuPAD
Before ordering or downloading MuPAD, you should make sure that
you have hardware good enough to run this program.

In order to run MuPAD on your computer, you need an IBM
compatible PC (Pentium I or higher) with 32 MB of RAM, a CD-ROM
drive, and about 40 MB of available disk space. Your system must be
running Windows 95/98/ME/NT 4.0/2000 or the Linux operating
system. However, 64 MB of RAM and a Pentium II with 400 MHZ
processor are recommended. You may also run MuPAD on the Solaris
operating system for SUN Sparc.

In order to take full advantage of the many resources provided by the
MuPAD team, you may also need an Internet connection and access to
e-mail.

The second thing you will need is of course the MuPAD program.
MuPAD is distributed by SciFace – a software company in Germany.
You can download a trial version of MuPAD which will work for one
month, from their web site at http://www.mupad.de. On this same
web site you will find information on how to order MuPAD, as well as
information about the Euclid program. This program was developed
for educators who want to test MuPAD in their classroom.

2.1 The Very First Look

In order to start MuPAD on Windows based system you need only to
click on its icon from the Start menu. If you going to use it frequently
it may be more convenient for you to place on the desktop of your
computer a shortcut to MuPAD executable file. It may look like this:

Now you are ready to start MuPAD. Double click the icon on the
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desktop and you will get MuPAD window on the screen of your
computer. It may at first look similar to the one in the enclosed
picture, but after a few days of using MuPAD you will certainly
introduce some modifications.

Fig. 2.1 MuPAD Pro version 2 screen
If this is your first contact with MuPAD you may want to read the
document on the screen or just start your first MuPAD explorations. In
order to start working with MuPAD choose the Filemenu and then the
option New Notebook, or just press [Ctrl][N].

CONVENTION: Throughout this book I will frequently ask you to press a key
or a combination of keys. It may look like this [Ctrl] or [Ctrl][N]. A
single square bracket means that you have to press a single key
with the given text or character; for example [Ctrl] means the
Control key and [N] the key with letter ”N”. Two keys with plus
between them will mean that you have to press these two keys at
the same time. For instance [Ctrl][N] means press [Ctrl] key, and
while holding it press [N] key. Combinations of keys like the above
[Ctrl][N] are called key sequences and these are very useful
shortcuts to many operations that are available through menus.

MuPAD is a command line program. Thus, in order to obtain any
result from it you have to type in the appropriate command and press
[Enter]. It may look like this:
 1.78  1.2 /* now press [Enter] */
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2.98

 123  345

468

The bullet on the left side means that you are ready to type in a
command that shall be performed by MuPAD. We will call the space
to the right of the bullet the input region. On a Mac or in Unix, instead
of a bullet a different character will be used. Below the input region is
the output region. Every time you press [Enter] MuPAD tries to
evaluate your command and print obtained result. Usually, the text in
the input region is red and the output text or formula is blue.
However, for the purpose of this book I made both of them
black—this will make the black-and-white printout more clear.

Observe, they key [Enter] in MuPAD is used to evaluate the input,
while the key sequence [Shift][Enter] to break an input line. If you
feel that this is not convenient, you may easily redefine it. I will show
you later how to do this. Now let’s practice some MuPAD commands
to taste its flavor.

2.2 Getting Started
We shall start with something simple, but not trivial. Otherwise you
would have a feeling that you are using a standard calculator. The first
difference between a standard calculator and MuPAD is the possibility
of typing in complicated formulae and getting the results at once. In a
calculator the same operation may take many steps. For instance
imagine that you going to calculate
123.897  23.987/67.987  763.98. In a calculator you will have to
first obtain 123.897  23.987 then obtain 67.987  763.98 and finally
divide first obtained result by second. In MuPAD you can obtain the
final result by a single command:
 (123.897  23.987)/(67.987 - 763.98)

0.2124791485

Now let’s do something more difficult, for instance let’s check how
MuPAD calculates large integers. For this purpose, a factorial of a
three or four digit integer will be ideal - say, 456!
 456!
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150777392777717065903328562798297482932764849966301\
315324902295697797980802999492049275470580840593582\
700556154654997912467653672836190567363944536581444\
396786039028419417159553169852939652733499484374432\
647121409002713034716885273557660568294514238651304\
204026421026217797122437474581042706674997505548774\
529387552185264469304745879944335896334980134727576\
771262477699704913814778801164976379963316514713032\
786305083016847394455111607701177156363125206697642\
497352441989049637406799105387152093299654856194446\
887474831405921359722324720996553956200165400519069\
670468845686118517860926559421327845227712982865242\
890852011587912148558934925229259778865164753102371\
910801614732061965104129730561590839408147446252948\
841011789641706225763887234100676084552005497753764\
496546383864694159909979495432469993306110242973486\
330432796522331628915418533758582252153753291412897\
349335363154308911927972242304805109760000000000000\
000000000000000000000000000000000000000000000000000\
000000000000000000000000000000000000000000000000

Well, you perhaps started wondering how far you can go with large
numbers in MuPAD. The best response is—just try. Calculate a few
more examples like the above and see what you can get. For example
how much will be 9999! and how much time it will take to calculate it.
Depending on how powerful is your computer it may take a few
seconds to a few minutes to obtain a very impressive result—a few
pages of digits ended by about 40 lines of zeros. It seems that we’ve
got quite an interesting toy.

Let’s try something different. For example let’s try to solve a few
equations.
 solve(x^2 - 2*x - 5  0, x)

6  1, 6  1

 solve(x^2  1  x^4, x)


2  5 1

2 , 2  5 1
2 , 2   5 1

2 , 2   5 1
2



Chapter 2: Quick Introduction to MuPAD 11

Both equations are very simple but imagine that you have to solve the
second equation by hand. It could take some time before you will be
able to write the final solution.

You have seen that MuPAD quite easily solves equations. How about
inequalities. These are usually painful problems for our students.
 solve(x^3 - 2*x^5  x  0, x)

0,1     ,1

In our solution we got two open intervals: ]-,1 and ]0,1[ which is
quite obvious if you try to plot the above inequality.

While working with mathematics we use a lot of plots. Let’s try to do a
few plots with MuPAD. First we start with a very basic plot of the
function y  sin2xcos3x.
 plotfunc2d(sin(2*x)*cos(3*x))
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The obtained picture looks very interesting, but what about 3D plots?
Let’s try a similar function but in 3D. Let z  sin2xcos3y.
 plotfunc3d(sin(2*x) * cos(3*y))
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The obtained graph was plotted with MuPAD default parameters, but
of course we can make it more accurate and choose only the part
which we need. We will come to MuPAD plots later.

You perhaps noticed that up to now all the operations were done in
the mode that is similar to the way how calculator works – type in a
single command and press [Enter]. However, in MuPAD you can go
much further. You can write programs like in many programming
languages. MuPAD programs are similar to Pascal programs. For
instance, can you recognize what the program given below is doing?
 n : 10:
MyFact : 1:
for i from 1 to n do
MyFact : MyFact*i

end

3628800

Well, it was easy to guess that this program calculates the product of
integers between 1 and 10. This means we shall get 10!. Let’s try to
check it in MuPAD:
 10!
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3628800

You have already learned a few interesting features of MuPAD and
now it is time to explore its interface.

2.3 A Quick Look at MuPAD’s Interface
You have already seen the MuPAD interface on your computer screen
or in the picture enclosed on the beginning of this chapter. It doesn’t
look very complicated and it certainly reminds you of many other
programs for MS Windows. You can easily identify the menu at the
top of the window and three toolbars: standard toolbar, format toolbar
and command bar.

Most of the menu options are similar to what you know from MS
Word and other programs for Windows. However, there are a few
things that are different and that are worth checking.

Using options from File menu you can open a new notebook – this is
what you will be doing frequently; save and print notebook. Do not
miss the option Export, where you can export your MuPAD notebook
as an RTF document or TXT file. Saving notebook as TXT is not too
much of use for us as we will lose all the formatting. However, when
you export your notebook as RTF document, you will be able to open
this document in any word processing program and all the formatting
will remain. Which means that the fonts, colors and pictures will be
like you had it in original MuPAD notebook.

The Edit menu looks exactly the same like in other Windows
programs, so you do not need to bother about this now.

Some of the operations from File menu and Edit menu are available
also from the standard toolbar:

Fig. 2.2 Standard toolbar in MuPAD

Using the View menu you can display or remove toolbars from the
screen. The most important for you may be the Options menu (Fig.
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2.3.) . Let’s take a look at it. You will find a few things there that you
may need in the future. Here you can change MuPAD’s default
behavior for the key [Enter] in the input regions. Just choose in
Evaluate On option ShiftEnter or Enter only.

Fig. 2.3 MuPAD Pro options

The most important for the rest of this chapter will be Output options.
If you wish to have nicely formatted text and formulae on the screen
and on the printout you should check the two check boxes: Typeset..
and Pretty print.. .

The Insert and Format menus you will use later while editing MuPAD
notebooks. In the Notebook menu, is a very useful option - Evaluate.
You can evaluate a single MuPAD input region and this works the
same way like [Enter], except that you can evaluate the whole
notebook from the beginning. This can be quite useful while working
on large projects or a simulation. For example, you can place in the
beginning of the notebook all declarations and evaluate notebook to
get final result; then, later, you may change these declarations and
evaluate the notebook again to get the results for the new declarations,
and again and again.
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The Debug menu will be useful in more advanced applications and
you may leave it for your later investigations. Finally, very useful is
the menu Extras. This is the place where you should look for shortcuts
to MuPAD operations. For example, if you do not remember a
MuPAD command or you do not wish to type long commands you
can choose them from this menu. Let’s try to use Extras to draw a 3D
plot. Just find the option: Plot 3D function. You shall obtain on the
screen:
 plotfunc3d(%?)

Now replace %? by the equation of your function and press [Enter],
for instance:
 plotfunc3d(3*sin(x)*cos(y))
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This is the easiest way to perform some less complicated MuPAD
operations. However, you should remember that the collection of
MuPAD commands and their parameters is so large that there is no
way to put them all in a menu like this.

Some of the most frequently used MuPAD operations are also
available from Command bar:
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Fig. 2.4 MuPAD’s command bar

There is another way to get a quick access to MuPAD operations. Let’s
try it. Suppose you wish to plot a graph of a function. In any input
region type pl (this is usually the beginning of names of many plotting
operations) and press [Ctrl][Shift]. You shall get a pop-up helper box
with names of all MuPAD operations that start with ”pl”. It may look
like this in the enclosed picture.

Fig. 2.5 MuPAD helper box

Now, you shall click the name of the operation you need and add
appropriate parameters. If many cases MuPAD will complete the
name of the command automatically.

2.4 Formatting Documents in MuPAD
We are used to working with nice documents where multiple fonts,
styles and colors are applied. The editing functions in MuPAD are a
bit limited but we should still remember that MuPAD is not a word
processing program nor a typesetting tool. However, you have here
enough of tools to make your notebook look nice.

You know already that in MuPAD there are two kinds of regions:
input and output region. Now is the time to find out that you may
have a third region for text. Thus, in one document you can mix text
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and calculations.

Fig. 2.6 MuPAD screen with text, input and output regions

Usually, MuPAD starts a new notebook with one input region on top
of the screen. In order to insert a text area above or below this region
choose from Insert menu option Text above or Text below. These two
operations are available through key sequences [Ctrl][F6] and [F6].
Now choose in the formatting toolbar an appropriate font, its size,
color and other parameters. The picture below shows what the
formatting toolbar offers.

Fig. 2.7 MuPAD’s formatting toolbar

You can change appearance of existing text by selecting it and then,
while selected, choosing from formatting toolbar appropriate
parameters.

There is a way to define editing parameters for the whole document.
For example you may wish to have all input commands in Letter
Gothic font, 10 points and in black. Or all output text in italics. In
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order to do this choose in Format menu option Fonts. You will get the
Font dialog box, where you can define all font settings (see Fig. 2.8).
Here you can choose your favorite font, color, size and attributes for it
and then apply these font settings to any region, text, input or output
region in your notebook (see Fig. 2.6). Do not forget to check the
option Apply to whole document. Changes done here will not affect
formulae in the output region. However, you can change them also by
going to the Expressions option from the Formatmenu.

Fig. 2.8 Font setting dialog box

MuPAD doesn’t allow us to delete or edit an output region. In order to
remove it or edit it, you must first change it to a text or input region by
using the menu Notebook and then apply an appropriate change.

In order to insert an input region above or below the current cursor
position choose from the Insert menu the option Input above or Input
below. These two operations are available through key sequences
[Ctrl][F5] and [F5].

2.5 Getting Help
While working with MuPAD, sometimes you may feel a bit lost. It
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happens that you do not remember a syntax of the command or exact
name of the command. In such case it is worth to check MuPAD about
the problematic issue. For instance let’s see what MuPAD can tell us
about the object student. You can ask about this in a few ways—by
issuing the commands info, help or just ?student. Here is how each of
them works.

Command info(student) produces the following output:
 info(student)
Library ’student’: the student package
-- Interface:
student::Kn, student::equateMatrix,
student::isFree, student::plotRiemann,
student::plotSimpson, student::plotTrapezoid,
student::riemann, student::simpson,
student::trapezoid

While commands:
 help(”student”)
 ?student

Will display MuPAD help browser box like this on Fig. 2.9.

By clicking on [Display] button you are going to get very detailed
hypertext help pages with a number of examples showing how the
command can be applied. Each term with yellow background is linked
to a page with further explanations. For example, by clicking on the
word examples with a yellow background you will go to a page with
examples showing how to use the given command. You can copy each
example to your notebook by clicking arrows  with green
background in front of the example.
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Fig. 2.9 MuPAD help browser

Fig 2.10 Help page for the student library

The MuPAD help browser can be useful for learning about MuPAD
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features. You can search for a given word which is not necessarily a
MuPAD command, you can browse the MuPAD manual, tutorial and
other files included with your copy of the program.

MuPAD help files cannot be printed; however, if you are connected to
the Internet you can always access the online help and print the pages
that you are interested in.

2.6 Chapter Summary
Before we proceed to the next chapter, let’s take a look at what we
have learned in this chapter.

We got accustomed to the MuPAD interface and the notebook’s
structure. We had also learnt a few MuPAD shortcuts and
instructions. Here are all of them.

2.6.1 MuPAD Shortcuts

[Ctrl][N] - open a new notebook
[Enter] (in the input region) - execute the command
[Ctrl][F6] - insert text region above current line
[F6] - insert text region below current line
[Ctrl][F5] - insert input region above current line
[F5] - insert input region below current line
[Ctrl][Shift] - complete a MuPAD name

2.6.2 MuPAD Instructions

n! - produce factorial of integer n
solve(equation) - solve an equation with one variable
plotfunc2d(function) - plot a graph of a function of one variable
plotfunc3d(function) - plot a graph of a function of two variables
info(command) - display basic information for given command
help(”command”) - display help pages for the given command
?command - display help pages for the given command
Note that the help command requires that its parameter be given with
double quotes (i.e. as a string).
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2.7 Review Exercises
1. Open a newMuPAD notebook and save it as review_01.mnb.
Above the existing input region insert a text area. Place the
cursor at the beginning of the text line and use the formatting
toolbar to change the font settings to Arial, 18 points, Bold, color
Maroon. Now type there Review exercises, set 1. This is
the title of your notebook. Below the title insert a new line for
text (just press [Enter]) and change its font settings to Times
New Roman, italic, 16 points, color Navy. In this line type
Calculations in MuPAD. This will be the title of the first
computing section.

2. Place the cursor beam at the beginning of the input region below
the section title and type in the command to calculate
234/345  34/789. Press [Shift][Enter] to obtain result. In the
same way, calculate 3455899999/234567, 33!, 333! and 3333!

3. Below the last output, create a new text area and change its font
to Times New Roman, italic, 16 points, color Navy. In this line
type MuPAD 2D plots. This will be the next section of your
notebook. Below it, insert a new input region.

4. In the last input region type command to plot function
y  sin5x  cos3x and obtain its plot. In the same way, obtain
plots of functions y  1/x sinx, y  sin1/x, y  x sin1/x.Each
command should be typed in as a separate input. You shall
obtain four separate plots.

5. Now it’s time to practice 3D plots. Below the last picture insert a
new line for text and again set its font to Times New Roman,
italic, 16 points, color Navy. In this line, type MuPAD 3D plots
and insert a new input region below.

6. Type in the commands to plot 3D plots of functions:
y  1/x sinxcosy, y  sin1/xy, y  xy sin1/xy. Again, you
shall type in each command in a separate input region and you
shall get three separate plots.

7. At the end of your review notebook insert a new section entitled
MuPAD help. Like other headers before, set it in the Times New
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Roman font, italic, 16 points, color Navy.

8. Below the last header insert a new input region. Type here in
and then press [Ctrl][Shift]. From the pop-up helper box choose
the info command. Now use the info command to get
information about plot and solve. Use help and ?solve to get
more information about solve command. Reminder:
help(solve)will not work, you shall have to use
help(”solve”).

9. Finally, go to the Notebookmenu and click on Delete Output.
This will remove all outputs from your notebook. Now calculate
all commands in your notebook again – you shall go to the
Notebookmenu and choose there Evaluate and then Any Input.

10. Save your notebook.




